×

Поиск строк в сметных объектах

Операция поиска строк в существующих сметных объектах вызывается:
  • из пункта главного меню Поиск/Поиск строк;
  • при нажатии на кнопку на панели инструментов таблицы строк ЛС;
  • при использовании сочетания клавиш Ctrl+F.
 
 
Окно Поиск строк разделено по группам управляющих элементов на следующие области:
  • Что искать - ввод одного или нескольких фрагментов текста (образцов) для поиска.
Логическое "И" между полями ввода означает, что поиск производится на одновременное наличие всех образцов, набранных в полях ввода.
Для каждого из полей ввода 10 последних введенных образцов поиска запоминаются и могут быть выбраны из списка повторно. Для этого, находясь в соответствующем поле, следует нажать клавиши Alt+Down или щелкнуть мышью на стрелке справа от него.
Кнопка Очистить в правой части группы позволяет одновременно очистить все поля ввода образцов.
  • Как искать - указание, каким образом образцы должны быть расположены в тексте.
При выборе опции в любом месте строки,  введенные образцы должны одновременно присутствовать в тексте, при этом их взаимное  расположение не имеет значения.
При выборе опции в начале строки в группе Что искать остается только одно (первое) поле ввода;
  • Область поиска - указание области поиска: текущая смета, текущая объектная смета, текущий или все проекты системы;
     
  • Поля - определение столбцов таблицы строк ЛС, текст из которых анализируется при поиске на наличие в нем введенных образцов;
  • Параметры поиска - определяются дополнительные параметры поиска. При установленном флажке в поле Учитывать скрытые проекты поиск проводится во всех проектах базы данных системы. Поиск прекращается, если количество найденных строк превышает значение, заданное в поле Лимит объема результатов поиска. При значении равном нулю, ограничение на количество найденных строк не накладывается.
     
Для выполнения поиска следует нажать кнопку Найти. Найденные записи будут показаны в открывшемся окне Результаты поиска, а их количество выведено в левом нижнем углу в статусной строке окна.
 
 
Окно результатов поиска представляет собой не редактируемую таблицу со списком строк и вкладками детальных форм строки. В зависимости от заданной области поиска, в таблице отображается шифр ЛС (ОС и проекта) - информация, позволяющая точно определить, какой ЛС принадлежит та или иная строка.
В окне Результаты поиска доступны следующие операции:
  • Повторить поиск с новыми параметрами - пункт меню Поиск  или кнопка на панели инструментов.
    Откроется окно Поиск строк, в котором можно ввести новые параметры поиска;
  • Перейти к строке сметы - пункт меню Данные/Перейти к строке или контекстного меню таблицы строк, кнопка на панели инструментов;
  • Копирование строк -  с помощью пункта меню Правка/Выделить выделяется строка или группа строк и копируются в буфер обмена с помощью пункта меню Правка/Копировать, контекстного меню таблицы строк ЛС или кнопки на панели инструментов.
     
Скопированные в буфер обмена строки можно вставить в любую локальную смету.
 
Для выделения всех строк можно использовать меню Правка/Выделить все или контекстное меню таблицы строк.
Снять выделение можно, используя меню Правка/Снять выделение или контекстное меню таблицы строк.
Детальные формы текущей строки ЛС могут быть отображены/скрыты с помощью пункта меню Вид/Показать детальные формы.
Выход из окна результатов поиска выполняется с помощью пункта меню Данные/Закрыть или при нажатии на кнопку на панели инструментов окна.